Making Wearable Badge Art with Printed Circuit Boards

Created by Anne Barela


Last updated on 2023-10-17 06:09:51 PM EDT
# Table of Contents

## Overview
- Software

## Translating Art into PCBs

## How This is Done
- What Makes a Printed Circuit Board?

## Mapping Art Layers to PCB Layers
- Mapping Art Layers to PCB Layers
- A Very Important Note on How Layers are Specified
- Debugging Image Layer to PCB Layer FAQ

## Creating the NASA Logo
- What to Look For in a Graphics File
- What to Watch Out For in Handling the Graphic Layers

## Using Affinity Designer 2
- Decide on the Layers
- Arranging Elements
- Making Light Holes for LEDs

## Exporting for Gingerbread

## Using Gingerbread
- Open your SVG
- Ready to Export to KiCad

## Pasting the Gingerbread Data into the KiCad Footprint Creator
- Saving Your Footprint in KiCad

## Design Considerations
- How I Did It

## KiCad
- Designing the Back Circuit

## Back Circuit Layout
- Component Placement
- Routing
- Checking the Design
- Final Touches

## Fabricating Your Design
- Creating the Gerber and Drill Files

## Ordering
- Parameters
- Checks
Assembly and Use

• Modification
• Soldering
• Final Check
• Mounting
Overview

In a previous guide, I introduced you to making art printed circuit boards (PCB) by making some floppy disk jewelry.

This guide expands on the concept. As you've likely seen on the internet, one can make art PCBs that also have functional electrical circuits on them. This is one of the best examples of STEAM (science, technology, engineering, art, and math) all coming together.
To demonstrate this next step in PCB art, I have taken the NASA logo (often called "the meatball") to make a pendant or pin.

The design starts much like the floppy design (), so I suggest you familiarize yourself with the tools used via that guide.

This guide uses KiCad to generate an electrical circuit on the back of the piece. Two LED lights will shine through the board to the front.

Software

KiCad Version 7.x () - KiCad 7 is the latest iteration of the venerable PCB design software. It came out in February, 2023, and so other tutorials using earlier versions are likely out of date as to the steps used to make art. For this tutorial, KiCad 7 is used to import art into a component footprint which is used to define the board files for the PCB manufacturer. The software is free - a donation is requested to keep development going.

Gingerbread () - a web-based tool hosted on Winterbloom () by Thea Flowers. Taking a specially formatted vector file SVG, Gingerbread parses the file into the footprint layers. The results can be pasted into the KiCad footprint editor to make the art into a PCB. The author notes: "This tool is extremely tailored to Winterbloom's needs. It's not perfect, it's not universal, and it probably won't work the way you think it will. Because of this, it comes with no warranty and no promise of support - again, we won't be
providing any free support for this.” The code is on GitHub and the GitHub repo notes other similar programs. Free to use without support.

Affinity Designer 2 () - used to make SVG files that Gingerbread accepts. Similar programs are Adobe Illustrator and Inkscape, but they may not produce the precise type of file Gingerbread accepts, so substitution would be the user's choice (without support). $70 and there is a free 30 day version that has all the features needed.

Translating Art into PCBs

The following two pages discuss using a vector art program to map an art piece into various elements, the construction of a two layer printed circuit board, and how one maps the design layers onto the circuit board layers.

Keep in mind that a circuit board has 4 distinct layers per side and the colors for silkscreen and solder mask tend to be limited by the board manufacturer. This will limit your design but it's part of the challenge to have art made on PCBs.

How This is Done
To create images on a computer, there are a number of methods to do so. Generally, they involve either pixel-level editing (Windows Paint, Mac Paint, Adobe Photoshop, Affinity Photo, etc.) and vector-level editing (Adobe Illustrator, Affinity Designer, Inkscape, etc., and even Microsoft PowerPoint). Vector editing uses lines and curves to make up objects in an art piece while pixel editing takes groups of individual pixels (dots). While pixel editing is more common, it is vector editing that allows for very easy changes to a design.

Typical editors of both types tend to rely on a layered design. While Windows Paint is only a one-layer editor (if you overwrite something, it is now part of the image), layers can be thought of as a stack of pictures that when added together form a complete image.

Layers work particularly well as PCBs are also made up of layers.

What Makes a Printed Circuit Board?

The substrate, a fiberglass layer usually designated FR-4, is not changeable by the PCB design. It is similar to a canvas with the color being whatever the board house uses, typically greyish, perhaps greenish.
Copper layers are on either side of the substrate (for a two-sided board which is typical for our use) and can be milled into many shapes.

Solder mask layers are used on the PCB to insulate the copper from the surface and are handy to manipulate for art.

Finally, silk screen layers provide the last bit of customization as to printing on a layer and usually text or designs are on these layers.

Holes may be drilled through the PCB during manufacturing, if you wish, for decoration or as a way to hang your art.

The silk screen, solder mask, and copper afford three layers for customization. Some designs even use the lack of these three layers, exposing the substrate, to be a fourth layer. The art process will specify the shapes of the three layers to make an artistic piece. With a two-sided board, there is an opportunity to either make a one-sided piece or a two-sided piece.

Another thing you can specify is the boundary of the art piece. This is designated End Cuts, as a mill will route an outline around your board.

---

**Mapping Art Layers to PCB Layers**

This is the magic in PCB art - taking a vector drawing and converting it into a circuit board. To make this happen, this guide uses Gingerbread by Winterbloom.

To achieve this, the image layer names are chosen to match the PCB "sandwich" shown below. On each side of the PCB, there is the silk screen, solder mask, copper, and unchangeable substrate.

---

![Mapping Image Layers to PCB Layers](image-url)
The layer names are on the left in the image and correspond to the layers shown at right.

You cannot change the layer order of a PCB, like have silkscreen between the copper and solder mask. Those are fixed by the factory, as they correspond to how the circuit boards are made for consumer goods. Part of the artistry is using the layers that are available and designing them to look good with that fixed number and positioning of layers.

A Very Important Note on How Layers are Specified

For the Front and Back silkscreen layers -- F.SilkS and B.SilkS -- and for the Front and Back copper layers -- F.Cu and B.Cu -- material will appear in KiCad wherever you draw a shape in the design.

For example, if you draw a Copper Circle, that is where the copper will appear in the copper layer.

If you draw a shape on a silkscreen layer, the silkscreen color will be deposited. It may be up to the board manufacturer if silkscreen can be printed on copper without a solder mask between. If you can, it might be best to specify silkscreen below areas you want to have silkscreen.

KiCad and Gingerbread treat the Front Mask F.Mask and Back Mask B.Mask as inverted! Where there are items in these layers, the solder mask will NOT be present. The preview in Gingerbread will show the mask layers as they would appear on the printed board.
Edge Cuts and Drills are special also. The **Edge.Cuts** layer specifies the outline of the circuit board. This could be simple, like the nearly square floppy earrings on the Overview Page. Or the design may be more complex like the weasel above. For interior edge cuts, see the FAQ below.

The **Drills** layer is very special also: Gingerbread walks through all of the shapes in that layer and converts only circles into corresponding non-plated, through hole drills in KiCAD. It is very easy to draw an ellipse instead of a perfect circle. Don't! Gingerbread will ignore non-round shapes in the **Drills** layer.

So, if your Gingerbread **Drills** layer does not show a hole, it is not that another layer has "covered it up" - likely the object is not circular.

### Debugging Image Layer to PCB Layer FAQ

**Q:** I drew circles in the **Drills** layer but they don't show up in **Gingerbread**.

**A:** Check they are indeed circles and not ellipses - the horizontal and vertical dimensions of a circle must be exactly the same. A physical drill can technically only drill round holes (end mills are used for slots).

**Q:** On a Mask layer, the material is where I don't want it and not where I specified.
A: The **F.Mask** and **B.Mask** layers are special. You must draw where you DON'T want mask material.

Q: Besides outside Edge cuts, can there be interior cuts?

A: Circular drill holes are the most common. But yes, some PCB manufacturers allow for cuts within the PCB outer perimeter. Be sure your manufacturer can handle such cuts. The gear below on the [Winterbloom Gingerbread page](#) has four interior cuts.

---

**Creating the NASA Logo**

![NASA Logo](image-url)
Ladyada suggested the NASA logo for the front of the piece. It's a good choice for PCB art in that it has a limited number of colors (three: blue, white, and red). The plan is to add two reverse-mount LEDs to illuminate two of the large stars in the top part of the logo.

My first issue was trying to get this logo from the bitmapped graphics PNG format to a vector art form in Affinity Designer 2. Tracing the major characteristics like the lettering, red "swoosh" and ellipse proved challenging.

Then I thought of finding a version of the logo already in a vector format.

There are several free logos on the internet in various vectorized formats. Wikipedia has one in SVG format. I found the free to use encapsulated postscript logo above at seeklogo.

What to Look For in a Graphics File

As described in previous pages, graphical vector elements that can be mapped to the various PCB layers are most desirable. The EPS file had more layers than a PCB but some were for various groups of stars, easily combined into one white silkscreen layer.

What to Watch Out For in Handling the Graphic Layers

Look at the red "swoosh" as I call it. In some cases, it appears to go underneath the NASA lettering on the left but over the bottom of the letter S and the lower half of the ellipse. This will be handled in Affinity Designer 2 on the next page.

Using Affinity Designer 2

I started by opening up the vectorized file I chose (NASA.eps). It consisted of one visible layer.

Click the v symbol in the layer and you'll see dozens of design elements that make up the logo.
Decide on the Layers

Given the elements, it made the most sense to use the following layers:

Silkscreen: White

Soldermask: Blue

There was not a red available. So I made the design decision the "swoosh" would be bare copper (actually ENIG, discussed later). It'll look more gold than red but it adds to the PCB nature of the project.

I set up the layers per the Gingerbread convention:

Front Silkscreen: \texttt{F.SilkS} - for the white elements

Front Copper: \texttt{F.Cu} - for the swoosh and under the silkscreen and soldermask parts (essentially the whole board)

Front Soldermask: \texttt{F.Mask} - Due to Gingerbread and KiCad conventions, the soldermask is specified where you DO NOT want soldermask. This would be any visible parts of the copper "swoosh" but noting the white lettering (and hence some soldermask beneath the silkscreen) covers the copper.
Arranging Elements

Make new layers in the drawing named **F.SilkS**, **F.Cu**, and **F.Mask**.

Start by moving all the star elements, which include the triangles ("star rays") into the **F.SilkS** layer. You can move the N and first A in that layer also.

The S and the last A are broken by the bottom part of the "swoosh". If they are not already in parts, trace the individual parts so you can put them in the **F.SilkS** layer.

The Swoosh copper should not have blue soldermask. Trace the parts that include the parts of the swoosh that correspond to areas that cover. You can add the entire swoosh then use the Subtract tool to get these traced items to not have soldermask removed. Yes, it seems backwards but you can import your intermediate file saves into Gingerbread to see how it's going. Most designs are not this complicated.

The last silkscreen item should be the ellipse. It is broken by the Swoosh too. So make it with the main ellipse and the part below the bottom part of the swoosh.
Making Light Holes for LEDs

The two large stars in the top portion of the logo is where I wanted LEDs to shine through. I took perfect circles centered on the rays and put them into a layer named Drills. The rest of the LEDs are handled on the back side.

Next: to make the footprint in Gingerbread.

Exporting for Gingerbread

Save your work at this point in Affinity Designer 2 by using File -> Save. That will result in a .afdesign file with your work.

To export the file from the native .afdesign format to an SVG file for Gingerbread, go to the File menu and click the Export option.
At the top of the dialog box of options, select SVG.

The current Gingerbread site has a picture of the export settings for a previous version of Affinity Designer. The current version is Affinity Designer 2 (or higher) and the menu changed.

The settings below map to the ones Gingerbread wants. If the Raster DPI is blank, do not set it using the dropdown. Manually type in 2540.
Once all the settings are correct, click the Export button in the lower right to save the file as an SVG file. This is the file you will drag and drop in the Gingerbread application (note: not the .afdesign file, Gingerbread only takes especially formatted SVG files).

Using Gingerbread

Open Gingerbread by going to gingerbread.wntr.dev in your modern web browser. You’ll see a screen like the one below.

There are three example designs you can look at to see how Gingerbread does its thing. You can also download the associated .afdesign files and look at how they were created in Affinity Designer 2.
Open your SVG

In your file application (Windows, for example, would be File Explorer), open up the directory containing your SVG file made with Affinity Designer 2. Drag the SVG file to the blank area below the existing examples.

If Gingerbread parses the SVG file as valid, you will have a screen similar to the one below. If it doesn't work, check the settings used to export from Affinity Designer 2 from the previous page.
You can toggle the layers on and off in the lower right. You can change the color of the solder mask and silk layers for better viewing.

Use the view to make sure all the layers are the way you want. You can separate the layers and view the back with the black buttons at the bottom of the frame.

The colors you select for solder mask and silkscreen are only for visualization in Gingerbread. They will not be exported to KiCad. Generally these are specified during submission to make the boards and not in the data file.

As an example of the warning above, you can use any colors you wish in Gingerbread, but for the OSH Park normal service, the Solder Mask color is purple and the silkscreens are white. You can change to their Black PCB service "After Dark", but that only provides a Black solder mask.

Other PCB fabricators, such as JCLPCB and PCBWay, may have more flexible options. Be on the lookout.
Ready to Export to KiCad

If the design is looking like you want it, you then click the "Export to Clipboard" button in the lower right part of the window. This will load the clipboard with the data the KiCad Footprint Editor expects for a new footprint (part).

Pasting the Gingerbread Data into the KiCad Footprint Creator

At this point, you should have used Gingerbread to load your clipboard with footprint data.

Open KiCad. As of this guide, the version is 7.x. You should get the following screen if you've opened the main KiCad application and not one of the submodules:

Open the KiCad main window and then Open the Footprint Editor by clicking the chip icon shown below.
Here is the KiCad Footprint Editor:
Click the New Footprint Icon (circled in red on the left) or use File -> New Footprint.

Select a name for your footprint -- since it isn't a standard component, for the Footprint Type select Other.

The text that appears is used in a standard circuit. As we do not want our design labeled by KiCad, click each line of text and press the Delete key to get rid of it, giving a blank slate in the central footprint area.

In the central footprint window, right-click and select Paste. Or use File -> Paste.

If the Gingerbread data is still in the clipboard, it will paste your design into the Footprint Creator. If it doesn't, go back to the Gingerbread web window and press the Export to Clipboard button again and try to paste once more in KiCad.
Saving Your Footprint in KiCad

You should then see your design. Move it so it is centered in the footprint area and click your mouse to "drop" it.

You'll rarely need to do anything else here. If there is anything you want on the PCB that is not available in the Affinity Designer 2 -> Gingerbread -> KiCad workflow, you can do that now. Most times, you can just select File -> Save and you'll get a dialog to save the footprint.

You should look to make a new library for your design - I selected "Anne". Do this using the New Library button located on the lower left. I named this footprint "NASA Badge". Click Save.

Now you have your design in a footprint library, congratulations. Nearly done! Yes, it's a lot of steps, but worth it when you open that package from the board fab with your design.
I'll slide this page here: The design on the previous page did not work when fabricated.

As I mentioned in the part about choosing silkscreen colors, each factory has their own design criteria. I have seen PCB art designs with sharp edges so I didn't have many worries about "the meatball" with the points of the swoosh exposed.

But I chose JLCPCB for this fabrication as they offer blue soldermask with white silkscreen. But their minimum size for parts of the board are 5mm. The points were too small and they could not guarantee they would not break in manufacturing.

It was decided to make an outside diameter to encompass the points and a hole at the top of that so it could be worn as a pendant if desired.

These changes were made in the KiCad footprint editor rather than in Affinity Designer 2 and Gingerbread.
How I Did It

In the Footprint editor, I clicked the Edge.Cuts layer. The layer has the outline of the Meatball logo with points. I changed that to Silkscreen to have a white line around the logo.

I then used the circle tool to make a new Edge.Cuts object to be a circle encompassing all pointy elements.
A hole was added at the top with a test point footprint widened a bit to over a millimeter for a loop, if desired.

Use the 3D viewer in KiCad View->3D Viewer (or Alt+3) to see how it looks (below).
If you don't already have a project, click File -> New Project. Select the name representing your design.

Go back to the main KiCad menu and click on PCB Editor (the green one).

The PCB Editor looks like the screen below:
Near the upper right is an icon of a chip. That is the Add a Footprint tool. Click it and you get a window to select a footprint. Select your footprint library and your design.

Place it in the center of the PCB editor window.

Zoom out if necessary to see your entire sheet.

In the 3D Viewer (View -> 3D Viewer), you can see your front design.

Save your design into a file that should end in a .kicad_pcb file extension.
Designing the Back Circuit

When designing actual circuits, Affinity and Gingerbread are left behind, it's all done in KiCad (it is what it does best).

First is to use the schematic editor. The circuit uses two reverse-mount LEDs to shine through the board. A 3 volt CR2032 coin cell is used for power. A switch turns the lights on. Each LED wants about 20 milliamps of current. Doing the LED math (see "LED Calculator via Google if you'd like help), that's about 51 ohms resistance for each one.

KiCad has built-in footprints for some of these items:

- A Keystone CR2032 battery holder
- A CK Switches SPDT switch
- 1206 size 51 ohm surface mount resistors

DigiKey was consulted on reverse mount LEDs The Inolux IN-S124AR looked sufficient. The footprint editor was used to make a compatible footprint from the datasheet on DigiKey.

All the parts on the schematic were annotated with the footprint and the datasheet for reference and added to the custom library I have.
The parts can be bought at any supplier you want. For this bill of materials (BOM), I ordered the supplies for 5 boards plus some spares from DigiKey. (Note: No compensation or consideration was provided by this supplier for this project.)

---

**Back Circuit Layout**

![Back Circuit Layout](image)

Choose the back side of the board in KiCad. Select Tools -> Update Board from Schematic (shortcut F8).

![Properties](image)

I found it helpful to click on each component and in the properties listed at the left (picture above), ensure the Layer is "B.Cu" (Back Copper). If somehow it is Front Copper (F.Cu), click to change it. All the parts need to be on the back copper layer to be routable.
Once all the components are on the back layer, you can position them and connect them via wire traces.

**Component Placement**

First click each LED and move it to cover one of the holes in the top half of the board where there is a large star on the badge side.

![Diagram of component placement](image)

**Routing**

The Route Tool (pointed to by the green arrow) allows you to draw copper traces between parts. Before wires connect, there are little thread wires connecting each component end. Those are called "air wires" and are a guide to show you that two parts connect.

Refer to the schematic for how things connect together.

You can move any component you want but don't move the LEDs (although you can flop them if they're upside down). They shine to the front.
As you lay out parts, you'll look to connect them via a copper trace using the Route Tool.

Place a resistor to one side of each LED, the one side that will route to the battery negative (center). Looking at the schematic, the positive of the battery holder connects to both LEDs. Route the LED to it's resistor. Join the other sides of the resistor together.

Route the common of the two resistors just tied together to leg 2 of the slide switch. Leg 1 of the switch routes to the battery negative (center) terminal.

Route the positive of the battery holder (on the side tab) to the free side of each LED.

You can see how I laid out the components above. I arranged them within the original logo boundary and left some space in the middle.
Checking the Design

Be sure there are no tiny airwires visible and all the connections are per the schematic. Then go to Inspect -> Design Rules Checker to see that all the connections are correct and there are not extra connections or unconnected items.

Note that terminal 3 of the switch is unused so no routing from it is needed. Make any corrections necessary.

Final Touches

I clicked the silkscreen layer and added a rectangle in the dimensions of a magnetic pin back of anyone wished to make this a pin or brooch.
Fabricating Your Design

Creating the Gerber and Drill Files

While some PCB manufacturers can take a KiCad data file directly for a design, the introduction of KiCad 7 in 2023 has some manufacturers behind on supporting the new file format. No worries, we'll export the files needed. Select File -> Fabrication Outputs -> Gerbers shown below.

![Gerber and Drill Files](image)

Use the Plot button to generate the Gerber files. I recommend making a subdirectory under your project to put them in. After that press the Generate Drill Files button. Save the files in the same directory as the Gerber Files.

These files describe exactly what each layer should have with the drill files showing the exact place to have holes drilled.

Go to the directory with all the generated files. Zip all the files into one Zip file package. If a board house cannot use KiCad 7 files, they will definitely use the raw files, most often sent in a single Zip file.

Upload the Gerber and Drill Files as a zip file (latest)
Ordering

As mentioned earlier, you can select from a number of manufacturers in several countries. One of the main considerations is if they make boards in the colors you want.

The colors for this project are blue (board), white (silkscreen) and copper/gold (bare metal). I could get this combination at JLCPCB.com. (Note: this is not an endorsement and there no consideration given / sponsorship / discount for using them).

Parameters

There are a wide variety of manufacturing choices available. The more obscure ones take additional time as they must gather enough board designs to make an entire
panel. A PCB panel is a single board consisting of multiple individual boards. Once assembled, the panel is then broken apart, or depanelized, into the individual PCBs.

FR-4 is the most common board type and the one described earlier. For simple boards, one layer may be sufficient but two layer boards are more common and this guide's design uses both sides.

Choose the color for the board and silkscreen.

Two different finishes are available for exposed metal: HASL and ENIG.

**HASL** is when the board is dipped in liquid solder, making a silver finish. Lead & Lead-free (RoHS compliance) is usually available.

**ENIG** consists of an electroless nickel plating, covered with a thin layer of gold, which protects the nickel from oxidation. While a bit more expensive, it provides a pretty finish that will not oxidize readily.

The choices for this project are circled in green in the screen above. Note that this particular manufacturer has a minimum order of 5 boards.

**Checks**

The board house will look at your design to see if it is manufacturable according to their processes. Likely they will note any issues and get back to you with issues and you should go into KiCad to make adjustments (like I did with the pointy pieces of the swish).

Now sit back and wait until your boards come.
Assembly and Use

You have a box at the door and you rush to see what's inside - your PCB order!

Now is the moment of truth - do your boards match what you designed (or thought you designed). If you are good (or experienced or thorough), they'll be perfect. If not, you might have to make changes and resubmit.

For me, the Silkscreen on the "AS" in NASA isn't 100% (though I tried hard). And the holes I swear were there for the two stars to let the LEDs shine through are not fully drilled out for some unknown reason. Also my battery holder footprint is upside down but that doesn't affect the electrical design as it's symmetrical.
Modification

As my LED holes are filled with something, I used a very small drill bit to get the hole through. The positioning was 100%, when the hole was drilled from the front, it came out where the LED was to be mounted. I drilled each out before soldering the circuit.

ALso the battery holder works oriented as shown in the silkscreen or 180 degrees. Having the battery removal from the bottom allows for the pin backing.
I took the parts I ordered and looked to get to work. Boy are these parts small. Ladyada said 1206 resistors are fine but it takes time, tweezers and a steady hand. Be sure you have a soldering iron with a fine tip.

There are two types of tweezers in the Featured Products page for holding SMD parts while soldering.

If you have not soldered surface mount (SMD) parts with a soldering iron, see this tutorial.

For the diodes, I put them on last. I put a battery on and flipped the slide switch. I then put an LED on the pads to ensure it would light, soldering it (with the power off) if correctly oriented. If it doesn't light, turn it around and it should if your resistors, switch and battery holder are soldered correctly and a battery is in the holder.
Final Check

When everything is soldered, turn the circuit on to ensure it works and that the LEDs shine through the holes to the front (see below).

Mounting

If you want to use this as jewelry, you can do a couple things:

1) Use a Magnetic Pin Back () added to the back for mounting like a pin or brooch (see above).

2) Use a loop of wire through the top hole and make into a pendant with a chain going around your neck. Size the chain for where you want it to hang.

You can also put it on a backpack or any number of places.

Have fun with your PCB art!