3D Printed Flexible LED Glove with Conductive Filament
Created by Ruiz Brothers

Last updated on 2018-08-22 03:49:25 PM UTC
## Guide Contents

### Overview

- 3D Printed Circuits
- Inspire & Remix
- Tools
- Parts

### Customize

- How to make a hand
- Scaling Paths
  - Set up Illustrator to use pixles. 1 pixel = 1mm inside most CAD programs.
- Tracing your hand
- Draw conductive traces
- Stroke width
- Outline Stroke
- Extrude paths
- Coin Cell Battery Holder
- Strap Tabs
- Connecting Traces
- Traces in Z
- Subtract traces from hand
- Export for printing

### 3D Printing

- Dual Extrusion
- 3D Printer Slice Setting
- Align Origins
- Group models
- Place objects on bed
- Select face to lay flat
- Center and Arrange
- Assign models to each print head
- Enable and Adjust ooze shield
- Print speeds
- Select Processes
- Check toolpath
- Materials
- Clean up

### Assembly

- Test traces
- Installing Adafruit LED Sequins
- Apply conductive paint
- Dry Time
- Assemble straps
- Connect ground
- Test flexibility
- Wear it!
Overview

3D Printed Circuits
In this guide we’ll show you how to use conductive filament and glow in the dark Ninjaflex to create a flexible LED wearable!

This integrated circuit is semi-flexible and uses a coin cell battery to power 5 Adafruit LED Sequins. This project is aimed towards 3D Printer’s with a dual extruder.

This project was an experiment to see how well Ninjaflex could adhere to conductive PLA filament. The two materials bond well together and their attributes compliment one another.

Inspire & Remix
We think the concepts in this project can be used to create really cool elements for cosplay props and costumes. Integrating conductive filament into your designs will allow you to create embed circuitry. The conductive filament can also be used for capacitive touch sensors!
All the materials to build this project are available in the Adafruit shop.

Tools

- 3D Printer with Dual Extruder
- Hakko Flush Diagonal Cutters (http://adafruit.it/152)
- Hakku Wire Strippers (http://adafruit.it/527)
- Tweezers (https://adafruit.it/dQn)

Parts

- NinjaFlex Glow in the Dark Filament (https://adafruit.it/fK1)
- Diffused LEDs (https://adafruit.it/dLA) (5mm, 3mm) or Adafruit LED Sequins (http://adafruit.it/1758)
- Conductive Filament - ProtoPasta (http://adafruit.it/2080)
- Bare Conductive Paint (https://adafruit.it/fKf)
- CR2032 Lithium Coin Cell (http://adafruit.it/654)
How to make a hand

We started by tracing our hand on paper using a pencil to get the actual size. Instead of scanning the drawing, we simply took a photo with our phone. We can import the photo into a drawing app like Photoshop or Illustrator to trace the hand. We'll use vector paths to create the outline - this will allow us to import it into CAD software to create an 3D extrude.

Scaling Paths

Once we had our hand traced out with vector paths, we needed to scale them to closely match the dimensions of our actual hand.

When scaling paths in Illustrator or Photoshop, avoid using millimeters as the units of measurements. This causes unexpected scaling issues - ie. parts set to 10mm x 10mm won't actually be 10 x 10, instead it gets 28.35 x 28.35mm.

Set up Illustrator to use pixels. 1 pixel = 1mm inside most CAD programs.

For more information on scaling issues, check out our Layer by Layer tutorial on YouTube. (https://adafruit.it/fKg)

Tracing your hand

Make sure your hand can actually fit on your 3D printers bed!

You'll want to lay your hand flat with your thumb resting aligned with your index finger. Don't spread your fingers out too much, otherwise your hand might not fit on your print bed.

Draw conductive traces

Measure the distance between the two soldering pads on the Sequin LEDs - we'll use this value to draw our conductive pads.
Draw the traces using single vector lines using the pen tool in Photoshop or Illustrator. Next, draw out the ground and power traces for each finger.

**Stroke width**

In Photoshop or Illustrator, you can apply a stroke thickness to single vector paths. We suggest making the traces at least 5px thick to ensure good conductivity along the trace.

**Outline Stroke**

Once you have your traces drawn out with single vector paths and in the spot you'd like, we need to create "outlines" of the single paths so they're extrudable. We can lock-in the stroke thickness by outline the strokes. In Illustrator, that option is under:
Object > Path > Outline Stroke

Now we can use the "save as" option to save the paths out as .SVG files - One for just the traces, and a second for just the hand outline. Now we can import them into our CAD program.

Extrude paths

Import the SVG files into your preferred CAD software. Extrude the hand outline and traces. The main hand body can be 1.5 mm thick while the traces are 1mm thick.

To avoid shorting the traces, you can insulate them by moving .25 mm off the ground, that way are sandwiched in-between the Ninjaflex printed hand.
Coin Cell Battery Holder

To power this project, we're using a coin cell battery. You can measure the diameter of the coin cell you plan to use. The holder can be a simple cylinder with a cavity for fitting the coin cell. You should run a print test of just the battery holder to ensure it has good tolerances. For getting a snap fit, try offsetting the inner diameter of the holder by ~0.2mm.

Test the coin cell holder tolerances before printing the entire hand!

Strap Tabs

To attach the Ninjaflex hand to your meaty one, we can add tabs to each finger for straps. These little tabs on the side of each finger has little slots. We can use them to attach the straps or rubber bands. The straps themselves can also be 3D printed in Ninjaflex.
Connecting Traces

To connect the LED's in parallel, we'll need to bridge a set of traces together. In this project, we bridged all the traces on the right using a curved trace, highlighted above. This curved trace actually sits above the left set of traces. Ninjaflex material will be layered on top, insulating it from the other traces.

Traces in Z

Since the left and right (power and ground) traces are in the same z-height, we used a series of cylinders with a height of .4mm to bridge the right(ground) traces to the top of the curved traces. No need to worry about overhangs because Ninjaflex material will be inbetween!
Subtract traces from hand

To make a proper tool path for dual printing, we'll have to subtract the traces away from the hand solid. This will allow one of the extruders to print the hand, while the other extruder can print the traces.

Export for printing

Save the hand and traces as separate objects, we'll combine them back together inside our slicing program.
3D Printing

Dual Extrusion

The parts in this project were optimized for a 3D printer with dual extruders. We prototyped this using the Flashforge Creator Pro. The traces are printed in Conductive PLA filament, while the hand is printed in Ninjaflex. These parts are printed in one piece and fused together.

3D Printer Slice Setting

Download the files to get started. If you're using Simplify 3D as your slice, use the recommend settings below. We have also included a Simplify3D profile for the Flashforge Creator Pro.

For other slicers, you can use the setting as a reference, but be warned that the values might not produce the same results.

https://adafruit.it/fKk
https://adafruit.it/fKk
https://adafruit.it/CfY
https://adafruit.it/CfY
### Align Origins

In Simplify3D, we'll import the files onto the print area. They're be'll in a unexpected orientation, so we can move all the object into the same origin by going to:

**Edit > Align Model Origins**

<table>
<thead>
<tr>
<th>File</th>
<th>Settings</th>
<th>Estimated Print Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hand.stl</td>
<td>235c Extruder, No Retraction, 20% infill, 2 Shells, 45mm/s print speed</td>
<td>about 1.5 hours to print</td>
</tr>
<tr>
<td>powerTrace.stl</td>
<td>235c Extruder, No Retraction, 20% infill, 2 Shells, 45mm/s print speed</td>
<td></td>
</tr>
<tr>
<td>groundTrace.stl</td>
<td>235c Extruder, No Retraction, 20% infill, 2 Shells, 45mm/s print speed</td>
<td></td>
</tr>
<tr>
<td>Staps.stl</td>
<td>235c Extruder, No Retraction, 20% infill, 2 Shells, 45mm/s print speed</td>
<td></td>
</tr>
</tbody>
</table>

© Adafruit Industries  
https://learn.adafruit.com/3d-printed-flexible-conductive-filament-led-glove
Group models

To move/transform the files as one unit, we can create a group by going under:

**Edit > Group Selection**

Place objects on bed

Lay the group flat on the bed with:

**Edit > Place Surface on Bed**
Select face to lay flat

Hover over one of the triangles and click on a face to lay flat on the bed.

Center and Arrange

Select the **Center and Arrange** button to place the group in the middle of the print bed.
Assign models to each print head

Use the Dual Extrusion Wizard to assign each file to an extruder. Here, you'll need to be cautious of which extruder has Ninjaflex and Conductive Filament.

Enable and Adjust ooze shield

Most common issues with dual extrusion is messy mixing of the two materials. To minimize this, we can use an ooze shield around the model to catch any excess material. Refer to ooze shield settings at the top of the page.
Print speeds

Use slower print speeds when printing with NinjaFlex. 45mm/s with no retraction should print fine on a FlashForge Creator Pro.

Once you've carefully modified the slice setting, go ahead and generate the gcode by hitting "Prepare to Print".
Select Processes

If you have any extra processes, Unselect those and only choose the two colored ones.
Check toolpath

Select the Active Toolhead view to visualize the toolpath. Make sure the colors do not intersect each other.

If everything looks good, export and print!

Materials

The conductive parts can be combined with different types of filament. The most common filaments like NinjaFlex, Semi-Flex will do just fine but you can of course experiment with other flexible materials

Clean up

If there's any string or artifacts left over from the ooze shield, clean up the part by trimming them off using a pair of flush snips.
Assembly

Test traces

Before we connect the smaller Sequin LEDs, we'll want to check all the traces can actually flow electrons.

Do test this, we can simply connect any bare LED to each conductive pad. We can insert the coin cell into the battery holder and use a piece of copper foil tape to connect ground.

If the LED's are dim, that's OK - bare conductive paint will make the connections more solid. It may be dimming because of how loosey the leads are touching the conductive pads.

Installing Adafruit LED Sequins

Place the LED Sequin onto one of the finger pads. Take note of the polarity. The positive and negative symbols are noted on each LED Sequin. Since we're connecting them in parallel, they need ordered in the same way. If you get confused which is positive or negative, just follow the traces. You can choose which trace (left or right) can be ground
or positive. Once you’ve chosen, stick with it! The positive and negative symbols are also noted on most coin cell batteries.

**Apply conductive paint**

Bare conductive paint adheres well with conductive filament and NinjaFlex. We can use a couple of drops to help bind the Adafruit LED Sequins to the conductive pads.

Don’t apply too much paint, you could end up connecting both sides of the LED!

**Dry Time**

Allow the Bare conductive paint to dry for at least 15 mins before testing flexibility.

**Assemble straps**

To connect the finger straps, feed the tab on the end of each strap through the slits on each of the fingers. Use a tweezer to help fit the tabs in.
Connect ground

Cut a small amount of silicone stranded wire and use two pieces of copper foil tape to connect the ground rail to the battery.

Test flexibility

Once the paint dries, do a quick flex test to make sure none of the LEDs lift when bending your fingers. If you notice any LEDs lift, apply a small amount of paint on the top of the LED pads. Run the paint from the top of the LED pad to the conductive filament pads on the glove.
Wear it!

The bare conductive paint adheres to the materials pretty well, but you can knock them loose with a lot of force and movement. If you do find yourself stressing, small touch ups can be applied. Be sure not to touch or flex until the conductive paint dries.

You can also use UV / black lights help to boost light when using Glow in the dark NinjaFlex!